• <ruby id="tkqkj"><i id="tkqkj"></i></ruby><span id="tkqkj"><sup id="tkqkj"></sup></span>

    1. <optgroup id="tkqkj"></optgroup>

    2. <acronym id="tkqkj"></acronym>

      <cite id="tkqkj"><li id="tkqkj"></li></cite>
      您好!歡迎光臨云杰通信官網,我司專業提供企業SD-WAN SaaS應用加速、SD-WAN組網、云專線接入服務。
      新聞動態

      行業最新前沿技術分享

      首頁 公司簡介 新聞動態 常見問題

      MPLS技術實驗思路和步驟

      發布時間:2020-10-27瀏覽次數:260

      MPLS技術實驗思路和步驟

      MPLS

      MPLS包頭:共32bit,前20Bit用作標簽,21到23Bit的EXP(用于QOS),1Bit的BOS(標識是否為棧底,1為棧底)、最后8Bit是TTL。

      LSP:源到目的需要經過的路徑

      LSR:能夠理解MPLS標簽并根據標簽轉發數據包的路由器稱為LSR

      上游和下游:在一條LSP上,沿數據包傳送的方向,相鄰的LSR分別叫上游和下游,下游就是路由的始發者。換句話說數據源就是上游,目的地就是下游。

      LDP:標簽分發協議

      簡單地說就是用來為MPLS分發標簽的,提高數據的轉發速率。

      LDP分配方式:DU(下游主動發給上游)、DOD(上游向下游發送請求)

      16以下的標簽數值為系統保留

      LDP標簽保留方式:自由(保留)這個比較常用、保守(丟棄)

      LDP標簽控制方式:有序,這個比較常用、獨立(必需等LSR下一跳的標記)

      VRF:VPN路由轉發實例

      1、一張獨立的路由表,包括獨立的地址空間

      2、一組歸屬于這個VRF的接口的集合

      3、一組只用于本VRF的路由協議

      RD:(Route-Distinguisher)顧名思義就是路由區分用的,其實就是當地址相同的時候RD才起區分的作用,實際上只需要保證存在相同地址的兩個VRF的RD不同即可,這只有在發路由撤消時才能真正體會到RD的價值。PE從CE接收到IPV4路由加上RD后再發給其他PE。IPV4加上RD后變成了VPN-IPV4地址族(64Bit),建議為每個VPN都配置相同的RD。

      格式一般采用ASN:nn

      ASN代表As號碼,nn代表數字,另外一種是address:nn。

      RT:(Route-Target)它決定VPN路由的收發和過濾,PE依靠RT屬性區分不同VPN之間路由。簡單地說就是控制路由表只能有什么樣的路由或者只能出去什么樣的路由。有import和export之分,一般只采用both。

      標簽分發:MPLS提供兩層標簽,公網由LDP分發,私網由MP-BGP來分配。

      粗略的實驗思路和步驟,僅供參考。

      1、保證IGP的可通性,將必要的loopback口(用于mpls鄰居發現的Routed

      ID或叫transport

      IP)宣告進路由進程,否則必需在相連接口上強制啟用 mpls ldp router-id serial 1/1 force

      2、在相應的MPLS區域及相應的接口上啟用LDP,也可以全局啟用

      r1(config-if)#mpls label protocol ldp

      3、在設備相應接口發hello包查找鄰居

      r1(config-if)#mpls ip

      4、在兩端PE上配置普通BGP

      r1(config)#router bgp 100

      rR1(config-router)#nei 3.3.3.3 remote-as 100

      R1(config-router)#nei 3.3.3.3 update-source lo 0

      5、在PE上創建VRF(將需要VPN服務的對象放入虛擬路由表)

      需要通信的兩個用戶網絡之間VRF和RD值最好保持一致

      r1(config)#ip vrf vpn1

      r1(config-vrf)#rd 100:1

      6、在PE上將連接CE的接口劃入VRF,其數據的轉發決策取決于VRF路由表

      r1(config)#int s1/1

      r1(config-if)#ip vrf forwarding vpn1

      % Interface Serial1/1 IP address 14.1.1.1 removed

      due to enabling VRF vpn1

      r1(config-if)# ip add 14.1.1.1

      255.255.255.0

      劃入VRF的接口上IP地址會消失,需重新輸入

      7、在兩端的PE上分別創建MP-BGP

      r1(config)#router bgp 100

      r1(config-router)#address-family vpnv4

      創建address-family為vpnv4

      r1(config-router-af)#neighbor 3.3.3.3

      activate

      將正常的BGP鄰居在vpnv4里面激活

      r1(config-router-af)#neighbor 3.3.3.3

      send-community both

      強制發送擴展屬性

      8、為MP-BGP創建VRF

      r1(config)#router bgp 100

      r1(config-router)#address-family ipv4 vrf

      vpn1

      9、配置RT控制VRF路由表

      r1(config)#ip vrf vpn1

      r1(config-vrf)#route-target both 100:1

      允許RD為100:1的路由進出

      10、配置PE-CE的路由協議

      PE-CE啟用路由協議,讓PE獲知用戶的路由信息,并導入MP-BGP的VRF表以傳遞

      r1(config)#router rip

      r1(config-router)#version 2

      r1(config-router)#no auto-summary

      r1(config-router)#address-family ipv4 vrf vpn1

      PE發布路由都是在address-family中進行的

      r1(config-router-af)#no auto-summary

      r1(config-router-af)#network 14.0.0.0

      r1(config-router-af)#redistribute bgp 100 metric

      1

      將MP-BGP重發布進rip中,metric設為1,讓用戶知道遠程想要通信的路由

      對端PE-CE之間路由協議為OSPF時的重分布配置

      r3(config)#router ospf 100 vrf vpn1

      r3(config-router)#router-id 36.1.1.3

      r3(config-router)#network 36.1.1.3 0.0.0.0 area

      0

      r3(config-router)#redistribute bgp 100

      subnets

      對端CE上的OSPF配置為正常的OSPF配置

      11、將PE-CE間的路由重分布進MP-BGP

      r1(config)#router bgp 100

      r1(config-router)#address-family ipv4 vrf

      vpn1

      進入相應的address-family中重分布

      r1(config-router-af)#redistribute rip

      到此,PE上的VRF路由表已經有了遠程用戶的路由,不出意外是可以通信的。

      下面是一些測試截圖

      1、啟用LDP與mpls ip之后查看標簽分發

      2、查看兩端PE上的普通BGP建立

      3、在PE上查看創建的VRF

      劃入VRF的接口路由已從全局路由表中消失

      4、查看MP-BGP的建立

      5、PE-CE運行路由協議,并將MP-BGP重分布進二者之間協議時,PE上的VRF路由表

      成功獲取到用戶內部的路由

      6、在PE上將PE-CE運行的IGP協議手工重分布進MP-BGP

      查看PE上MP-BGP的VRF路由表

      7、兩協議重分布完成后在PE上再次查看VRF路由表

      成功獲取到遠程的192.168.1.0路由

      8、查看CE上的全局路由

      擁有直連和遠程用戶的路由

      9、CE成功與遠程用戶通信

      10、跟蹤路由,標簽正常分發

      11、PE與CE間的通信

      熱門產品
      SAAS應用加速 SD-WAN組網 SD-WAN云專線

      咨詢熱線1:136-3177-9516

      咨詢熱線2:0769-88900720

      公司地址:廣東省東莞市南城區東莞大道428號寰宇匯金中心9棟B座18樓(總部)

      主要業務Main Business
      行業解決方案Industry Solutions
      關于我們About Us
      在線客服微信

      獲取最新優惠

      Copyright ? 版權所有2021-2022 廣東云杰通信有限公司—SD-WAN服務廠商|SD-WAN組網方案 粵ICP備18062193號
      国产美女精品自在线拍免费
    3. <ruby id="tkqkj"><i id="tkqkj"></i></ruby><span id="tkqkj"><sup id="tkqkj"></sup></span>

      1. <optgroup id="tkqkj"></optgroup>

      2. <acronym id="tkqkj"></acronym>

        <cite id="tkqkj"><li id="tkqkj"></li></cite>